ASUS WS C621E SAGE Motherboard The Search For Incredible is Over

18

ASUS WS C621E SAGE Test Configuration

Here is our basic test configuration for this motherboard:

  • Motherboard: ASUS WS C621E SAGE Motherboard
  • CPU: 2x Intel Xeon Gold 6134 (8 core / 16 Threads)
  • GPU: ASUS Strix GTX 1080
  • Cooling: 2x Dynatron LGA3647 B5 – Active Type
  • RAM: 12x MICRON 16GB Low Profile
  • SSD: OCZ RD400
  • OS: Windows 10 Pro

The Intel Xeon Gold 6134 CPUs are Intel’s frequency optimized parts. You can see our Intel Xeon Gold 6134 server benchmarks and review where we discuss how they excel with licensing models employed by software such as Windows Server 2016.

We are not going to spend a ton of time on the benchmarks, but we wanted to show few numbers to highlight the performance.

AIDA64 Memory Test

ASUS WS C621E SAGE AIDA64 Memory
ASUS WS C621E SAGE AIDA64 Memory

Cinebench R15

ASUS WS C621E SAGE Cinebench
ASUS WS C621E SAGE Cinebench

Geekbench 4

ASUS WS C621E SAGE Geekbench
ASUS WS C621E SAGE Geekbench

PCMark 8

ASUS WS C621E SAGE PCMark8
ASUS WS C621E SAGE PCMark8

PassMark 9

ASUS WS C621E SAGE PassMark
ASUS WS C621E SAGE PassMark

Overall, the ASUS WS C621E SAGE performed extremely well. If you are building a high-end workstation using Windows Server 2016 for example, and are using frequency optimized parts, this is a great option to maximize per core performance. There is a bit more room to overclock, normally around 3% that can help these numbers even more.

Next, we are going to look at the power consumption before getting to our final thoughts.

1
2
3
4
REVIEW OVERVIEW
Design & Aesthetics
9.7
Performance
9.9
Feature Set
9.8
Value
9.6
SHARE
Previous articleTwin Lakes Intel Xeon D-2100 Platform Powering Facebook
Next articleGigabyte MB51-PS0 Review The Big Intel Xeon D Platform

18 COMMENTS

  1. How long do ASUS tend to support their workstation mb offerings?
    Regular desktop boards (even the ROG and the like) tend to not receive BIOS updates and the like for long after release, or they take a really long time to fix security issues. (Sabertooth X99 for example, still no BIOS with Spectre v2 microcode fix)

  2. One negative point, i have the ASUS X299 PRO/SE motherboard, which is the same as this one but with the X299 chipset and it also has the ASMB9-iKVM features.

    The KVM console function does not work properly when using a discrete graphics card with multiple monitors. The KVM tries to use the onboard chip for graphics which means you cant control it.

    Example, i have a 1070TI with 3 monitors, the onboard KVM (AST2500) acts as a 4th monitor. The KVM now displays only one monitor (the 4th) but acts as 4 monitors, which means the mouse is uncontrollable and windows arent visible (they open on one of the other monitors)

    Asus knows about this and says its working on a fix, but its not out yet.

    Also many sensors are marked as critical for me, even some voltages, this is also a problem recognized by Asus in the KVM firmware, waiting for a fix.

  3. Oh and another note, i wasnt able to view the BIOS via KVM either, because it was displayed on another monitor as well, so the screen stays black untill booted and logged on.

    Asus just released a new bios with option to select main GPU (onboard/discrete) so i will be trying this soon.

  4. I’d avoid ASUS and go SuperMicro every time.
    I have found ASUS’s BIOS updates to be lacking and they tend to stop being issued far too soon IMO.

  5. Warning!: The SQUARE heatsink will not fit! Make sure to buy a NARROW heatsink like the Supermicro SNK-P0068AP4

  6. I don’t see mention of the form factor, which is (disappointingly) EEB. I’m wondering what type of case you used.

  7. On Ubuntu 18.04.1 LTS (4.15.0-43-generic) dmesg shows the following error:
    [ ] pci 0000:00:00.0: aer_layer=Data Link Layer, aer_agent=Receiver ID
    [ ] {29}[Hardware Error]: Hardware error from APEI Generic Hardware Error Source: 0
    [ ] {29}[Hardware Error]: It has been corrected by h/w and requires no further action
    [ ] {29}[Hardware Error]: event severity: corrected
    [ ] {29}[Hardware Error]: Error 0, type: corrected
    [ ] {29}[Hardware Error]: section_type: PCIe error
    [ ] {29}[Hardware Error]: port_type: 4, root port
    [ ] {29}[Hardware Error]: version: 3.0
    [ ] {29}[Hardware Error]: command: 0x0540, status: 0x0010
    [ ] {29}[Hardware Error]: device_id: 0000:00:00.0
    [ ] {29}[Hardware Error]: slot: 0
    [ ] {29}[Hardware Error]: secondary_bus: 0x00
    [ ] {29}[Hardware Error]: vendor_id: 0x8086, device_id: 0x2020
    [ ] {29}[Hardware Error]: class_code: 000006
    [ ] pci 0000:00:00.0: aer_status: 0x00000040, aer_mask: 0x00000000
    [ ] Bad TLP

  8. xcxc,

    Did you manage to find out what the error was?
    Can you reply so we can chat offline re specs etc?

    Having same issue where the MoBo/Computer locks up/crashes at random times.

  9. Hi,

    I’m not able to access the UEFI BIOS (only the blue legacy BIOS)
    Therefore I’m not able to install my Intel SSDs using the U.2 ports.

    Does anyone had similar issues with the Board.

    Asus support is not able to fix the issue.

    Thanks!

  10. Hi Turkishlitecoin

    Great that it worked for you.
    I also have installed the latest version 3601.
    It still does not work.

    Here’s what happens after resetting CMOS:
    youtu.be/r08Lk–O6bM

    Any idea what’s wrong with the board?

LEAVE A REPLY

Please enter your comment!
Please enter your name here