ASUS WS C621E SAGE Motherboard The Search For Incredible is Over

18

ASUS WS C612E SAGE Motherboard Power Consumption

Power consumption can vary a significant amount depending on processors used and the number of HDDs/SSDs/Expansion cards used. Here we test just a primary system.

ASUS WS C621E SAGE Power
ASUS WS C621E SAGE Power

For our tests, we use AIDA64 Stress test which allows us to stress all aspects of the system. We do not stress test the GPU in these tests.

  • OS Idle: 143.35W
  • AIDA64 Stress Test: 403.59W

The ASUS WS 621E SAGE has a lot going on but its power consumption is in-line with expectations.

Final Thoughts

On the front of the retail box, a graphic says “In Search of Incredible”, we think ASUS did just this and created an incredible motherboard with the WS C621E SAGE.  When we saw pictures of this new motherboard back in October of last year, we could not wait to get ahold of one to run through our benchmarks. Finally, we received one, and it did not let us down.

ASUS WS C621E SAGE
ASUS WS C621E SAGE

We have used the Z10PE-D16 WS for years here in the lab; in fact, it’s running right now to do this review on, it has been a stable platform for years. We also saw the Z10PE-D8 in our piece the Puget Systems Genesis Workstation Experience

Boot times are faster and expanded storage options that bring the workstation series up to par with other workstation motherboards using the latest of Intel Scalable (codenamed “Skylake-SP”) processors.

The WS C612E SAGE also adds in an additional PCIe slot bringing the total to seven vs. six found on the Z10PE-D16 WS. We do lose memory capacity with only 12x DIMM (768GB Max) slots vs. 16 (1024GB Max) on the Z10PE-D16 WS, but we gain the benefits of six channels of DDR4 per CPU versus four per CPU on the previous generation.

The SAGE offers overclocking options like the Z10PE, but these are small bus speed increases. The performance was a bit higher than other dual processor motherboards we have tested so far.

We would also like to see 10G network options on board. On the other hand, we understand that not everyone requires this, and it would add a substantial extra cost to this motherboard. For those that need high-speed networks, you will require an add-on NIC which could interfere with quad-SLI setups. While 10Gbase-T/ SFP+ may have been easier to integrate, especially if ASUS used a higher-end PCH (read our Burgeoning Intel Xeon SP Lewisburg PCH Options Overview) higher-end networking such as 25/40/50/100GbE, Infiniband, and Omni-Path have different connector requirements.

The addition of BMC supplied by an ASMB9-iKVM chip is also welcome for those that need to run systems at the data center or remote locations. As we see more high-end workstation use for AI and deep learning, having the ability to remotely manage systems built on the ASUS WS C621E SAGE is a great option. Another key use case for this feature is converting a workstation to server duties. With dual Xeons, a Lewisburg PCH, and ECC RDIMM support adding remote iKVM is the key capability needed to make it useful as a server as well.

Is the ASUS WS C621E SAGE a worthy upgrade to the Z10PE-D16 WS? We feel it is.

1
2
3
4
REVIEW OVERVIEW
Design & Aesthetics
9.7
Performance
9.9
Feature Set
9.8
Value
9.6
SHARE
Previous articleTwin Lakes Intel Xeon D-2100 Platform Powering Facebook
Next articleGigabyte MB51-PS0 Review The Big Intel Xeon D Platform

18 COMMENTS

  1. How long do ASUS tend to support their workstation mb offerings?
    Regular desktop boards (even the ROG and the like) tend to not receive BIOS updates and the like for long after release, or they take a really long time to fix security issues. (Sabertooth X99 for example, still no BIOS with Spectre v2 microcode fix)

  2. One negative point, i have the ASUS X299 PRO/SE motherboard, which is the same as this one but with the X299 chipset and it also has the ASMB9-iKVM features.

    The KVM console function does not work properly when using a discrete graphics card with multiple monitors. The KVM tries to use the onboard chip for graphics which means you cant control it.

    Example, i have a 1070TI with 3 monitors, the onboard KVM (AST2500) acts as a 4th monitor. The KVM now displays only one monitor (the 4th) but acts as 4 monitors, which means the mouse is uncontrollable and windows arent visible (they open on one of the other monitors)

    Asus knows about this and says its working on a fix, but its not out yet.

    Also many sensors are marked as critical for me, even some voltages, this is also a problem recognized by Asus in the KVM firmware, waiting for a fix.

  3. Oh and another note, i wasnt able to view the BIOS via KVM either, because it was displayed on another monitor as well, so the screen stays black untill booted and logged on.

    Asus just released a new bios with option to select main GPU (onboard/discrete) so i will be trying this soon.

  4. I’d avoid ASUS and go SuperMicro every time.
    I have found ASUS’s BIOS updates to be lacking and they tend to stop being issued far too soon IMO.

  5. Warning!: The SQUARE heatsink will not fit! Make sure to buy a NARROW heatsink like the Supermicro SNK-P0068AP4

  6. I don’t see mention of the form factor, which is (disappointingly) EEB. I’m wondering what type of case you used.

  7. On Ubuntu 18.04.1 LTS (4.15.0-43-generic) dmesg shows the following error:
    [ ] pci 0000:00:00.0: aer_layer=Data Link Layer, aer_agent=Receiver ID
    [ ] {29}[Hardware Error]: Hardware error from APEI Generic Hardware Error Source: 0
    [ ] {29}[Hardware Error]: It has been corrected by h/w and requires no further action
    [ ] {29}[Hardware Error]: event severity: corrected
    [ ] {29}[Hardware Error]: Error 0, type: corrected
    [ ] {29}[Hardware Error]: section_type: PCIe error
    [ ] {29}[Hardware Error]: port_type: 4, root port
    [ ] {29}[Hardware Error]: version: 3.0
    [ ] {29}[Hardware Error]: command: 0x0540, status: 0x0010
    [ ] {29}[Hardware Error]: device_id: 0000:00:00.0
    [ ] {29}[Hardware Error]: slot: 0
    [ ] {29}[Hardware Error]: secondary_bus: 0x00
    [ ] {29}[Hardware Error]: vendor_id: 0x8086, device_id: 0x2020
    [ ] {29}[Hardware Error]: class_code: 000006
    [ ] pci 0000:00:00.0: aer_status: 0x00000040, aer_mask: 0x00000000
    [ ] Bad TLP

  8. xcxc,

    Did you manage to find out what the error was?
    Can you reply so we can chat offline re specs etc?

    Having same issue where the MoBo/Computer locks up/crashes at random times.

  9. Hi,

    I’m not able to access the UEFI BIOS (only the blue legacy BIOS)
    Therefore I’m not able to install my Intel SSDs using the U.2 ports.

    Does anyone had similar issues with the Board.

    Asus support is not able to fix the issue.

    Thanks!

  10. Hi Turkishlitecoin

    Great that it worked for you.
    I also have installed the latest version 3601.
    It still does not work.

    Here’s what happens after resetting CMOS:
    youtu.be/r08Lk–O6bM

    Any idea what’s wrong with the board?

LEAVE A REPLY

Please enter your comment!
Please enter your name here